#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((?:[A-Z]\.)+[A-Z]?|[a-zA-Z']+)"
Local $sString = "Consider this sentence: I studied at U.C.L.A in U.S.A.. One of my professors' kid was my best friend."
Local $sSubst = "$1\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)