import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:[A-Z]\\.)+[A-Z]?|[a-zA-Z']+)";
final String string = "Consider this sentence: I studied at U.C.L.A in U.S.A.. One of my professors' kid was my best friend.";
final String subst = "$1\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}