import Foundation
let pattern = #"((?:[A-Z]\.)+[A-Z]?|[a-zA-Z']+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Consider this sentence: I studied at U.C.L.A in U.S.A.. One of my professors' kid was my best friend."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)