import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)(\\\")([\\\"\\w\\s0-9]+)(\\\")(.*)";
final String string = "Anthing you wish before\"10 990 Points\"Anthing you wish after";
final String subst = "['\\1', '\\5']";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}