re = /(.*)(\")([\"\w\s0-9]+)(\")(.*)/m
str = 'Anthing you wish before"10 990 Points"Anthing you wish after'
subst = '[\'\\1\', \'\\5\']'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result