use strict;
my $str = 'Anthing you wish before"10 990 Points"Anthing you wish after';
my $regex = qr/(.*)(\")([\"\w\s0-9]+)(\")(.*)/mp;
my $subst = '[\'\\1\', \'\\5\']';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";