# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?s)^.*?number:\s([a-zA-Z0-9]+)//g;t' <<< "Today's serial is number: A12345
Today's serial is number: A12345"