package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)^.*?number:\s([a-zA-Z0-9]+)`)
var str = `Today's serial is number: A12345
Today's serial is number: A12345`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}