$re = '/(?s)^.*?number:\s([a-zA-Z0-9]+)/';
$str = 'Today\'s serial is number: A12345
Today\'s serial is number: A12345';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;