import Foundation
let pattern = #"(?s)^.*?number:\s([a-zA-Z0-9]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Today's serial is number: A12345
Today's serial is number: A12345
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)