#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)^.*?number:\s([a-zA-Z0-9]+)"
Local $sString = "Today's serial is number: A12345" & @CRLF & _
"Today's serial is number: A12345"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)