use strict;
my $str = 'Today\'s serial is number: A12345
Today\'s serial is number: A12345';
my $regex = qr/(?s)^.*?number:\s([a-zA-Z0-9]+)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";