const regex = /(?s)^.*?number:\s([a-zA-Z0-9]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)^.*?number:\\s([a-zA-Z0-9]+)', 'g')
const str = `Today's serial is number: A12345
Today's serial is number: A12345`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);