re = /(?s)^.*?number:\s([a-zA-Z0-9]+)/
str = 'Today\'s serial is number: A12345
Today\'s serial is number: A12345'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result