// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)^.*?number:\s([a-zA-Z0-9]+)").unwrap();
let string = "Today's serial is number: A12345
Today's serial is number: A12345";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}