# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/-(?=-)|(?<=\d)-(?=\d+(-\d+)?$)//gm;t' <<< "--1234
-123-123-1234
-123-123
12.123.3
---123.13.123"