$re = '/-(?=-)|(?<=\d)-(?=\d+(-\d+)?$)/m';
$str = '--1234
-123-123-1234
-123-123
12.123.3
---123.13.123';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;