re = /-(?=-)|(?<=\d)-(?=\d+(-\d+)?$)/m
str = '--1234
-123-123-1234
-123-123
12.123.3
---123.13.123'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result