const regex = /-(?=-)|(?<=\d)-(?=\d+(-\d+)?$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-(?=-)|(?<=\\d)-(?=\\d+(-\\d+)?$)', 'gm')
const str = `--1234
-123-123-1234
-123-123
12.123.3
---123.13.123`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);