#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)-(?=-)|(?<=\d)-(?=\d+(-\d+)?$)"
Local $sString = "--1234" & @CRLF & _
"-123-123-1234" & @CRLF & _
"-123-123" & @CRLF & _
"12.123.3" & @CRLF & _
"---123.13.123"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)