using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-(?=-)|(?<=\d)-(?=\d+(-\d+)?$)";
string substitution = @"";
string input = @"--1234
-123-123-1234
-123-123
12.123.3
---123.13.123";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}