import Foundation
let pattern = #"-(?=-)|(?<=\d)-(?=\d+(-\d+)?$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
--1234
-123-123-1234
-123-123
12.123.3
---123.13.123
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)