use strict;
my $str = '--1234
-123-123-1234
-123-123
12.123.3
---123.13.123';
my $regex = qr/-(?=-)|(?<=\d)-(?=\d+(-\d+)?$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";