import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-(?=-)|(?<=\\d)-(?=\\d+(-\\d+)?$)";
final String string = "--1234\n"
+ "-123-123-1234\n"
+ "-123-123\n"
+ "12.123.3\n"
+ "---123.13.123";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}