# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(IMG_.+\s*.*\..+.*\s*)(IMG_.+\s*.*\..+.*)/*from*\n$1$2\n\n*to*\n$2/gmi;t' <<< "IMG_7892.jpg | 3
Bilqis.JPG | 7
IMG_7892.jpg | 1
Bilqis.JPG | 8"