#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(IMG_.+\s*.*\..+.*\s*)(IMG_.+\s*.*\..+.*)"
Local $sString = "IMG_7892.jpg | 3" & @CRLF & _
"Bilqis.JPG | 7" & @CRLF & _
"IMG_7892.jpg | 1" & @CRLF & _
"Bilqis.JPG | 8"
Local $sSubst = "*from*\n$1$2\n\n*to*\n$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)