$re = '/(IMG_.+\s*.*\..+.*\s*)(IMG_.+\s*.*\..+.*)/mi';
$str = 'IMG_7892.jpg | 3
Bilqis.JPG | 7
IMG_7892.jpg | 1
Bilqis.JPG | 8';
$subst = "*from*\n$1$2\n\n*to*\n$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;