package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(IMG_.+\s*.*\..+.*\s*)(IMG_.+\s*.*\..+.*)`)
var str = `IMG_7892.jpg | 3
Bilqis.JPG | 7
IMG_7892.jpg | 1
Bilqis.JPG | 8`
var substitution = "*from*\n$1$2\n\n*to*\n$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}