use strict;
my $str = 'IMG_7892.jpg | 3
Bilqis.JPG | 7
IMG_7892.jpg | 1
Bilqis.JPG | 8';
my $regex = qr/(IMG_.+\s*.*\..+.*\s*)(IMG_.+\s*.*\..+.*)/mip;
my $subst = '*from*\\n$1$2\\n\\n*to*\\n$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";