import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(IMG_.+\\s*.*\\..+.*\\s*)(IMG_.+\\s*.*\\..+.*)";
final String string = "IMG_7892.jpg | 3\n"
+ "Bilqis.JPG | 7\n"
+ "IMG_7892.jpg | 1\n"
+ "Bilqis.JPG | 8";
final String subst = "*from*\\n$1$2\\n\\n*to*\\n$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}