import Foundation
let pattern = #"(IMG_.+\s*.*\..+.*\s*)(IMG_.+\s*.*\..+.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
IMG_7892.jpg | 3
Bilqis.JPG | 7
IMG_7892.jpg | 1
Bilqis.JPG | 8
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"*from*\n$1$2\n\n*to*\n$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)