# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<a (.*?)href="(.+?)"(.*?)>(.*?)<\\/a>/<a href="$2">$4<\/a>/gism;t' <<< "<a href="http://www.google.be">Google</a>
<a href="bestand.flv" test=\"blablabla\">bestand</a>
<a target="_blank" href="Titels_opdrachten.pdf"><strong>titels van opdrachten in OLAT</strong></a>
<a id="5quot;>test</a>
<a href="hallo.png">hallo</a>"