use strict;
my $str = '<a href="http://www.google.be">Google</a>
<a href="bestand.flv" test="blablabla">bestand</a>
<a target="_blank" href="Titels_opdrachten.pdf"><strong>titels van opdrachten in OLAT</strong></a>
<a id="5quot;>test</a>
<a href="hallo.png">hallo</a>';
my $regex = qr/<a (.*?)href="(.+?)"(.*?)>(.*?)<\/a>/ismp;
my $subst = '<a href="$2">$4</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";