import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a (.*?)href="(.+?)"(.*?)>(.*?)<\\/a>";
final String string = "<a href="http://www.google.be">Google</a>\n"
+ "<a href="bestand.flv" test=\"blablabla\">bestand</a>\n"
+ "<a target="_blank" href="Titels_opdrachten.pdf"><strong>titels van opdrachten in OLAT</strong></a>\n\n"
+ "<a id="5quot;>test</a>\n"
+ "<a href="hallo.png">hallo</a>";
final String subst = "<a href="$2">$4</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}