$re = '/<a (.*?)href="(.+?)"(.*?)>(.*?)<\/a>/ism';
$str = '<a href="http://www.google.be">Google</a>
<a href="bestand.flv" test="blablabla">bestand</a>
<a target="_blank" href="Titels_opdrachten.pdf"><strong>titels van opdrachten in OLAT</strong></a>
<a id="5quot;>test</a>
<a href="hallo.png">hallo</a>';
$subst = "<a href="$2">$4</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;