using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a (.*?)href="(.+?)"(.*?)>(.*?)<\/a>";
string substitution = @"<a href="$2">$4</a>";
string input = @"<a href="http://www.google.be">Google</a>
<a href="bestand.flv" test=""blablabla"">bestand</a>
<a target="_blank" href="Titels_opdrachten.pdf"><strong>titels van opdrachten in OLAT</strong></a>
<a id="5quot;>test</a>
<a href="hallo.png">hallo</a>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}