const regex = /<a (.*?)href="(.+?)"(.*?)>(.*?)<\/a>/gism;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a (.*?)href="(.+?)"(.*?)>(.*?)<\\\/a>', 'gism')
const str = `<a href="http://www.google.be">Google</a>
<a href="bestand.flv" test="blablabla">bestand</a>
<a target="_blank" href="Titels_opdrachten.pdf"><strong>titels van opdrachten in OLAT</strong></a>
<a id="5quot;>test</a>
<a href="hallo.png">hallo</a>`;
const subst = `<a href="$2">$4</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);