import Foundation
let pattern = #"<a (.*?)href="(.+?)"(.*?)>(.*?)<\/a>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
<a href="http://www.google.be">Google</a>
<a href="bestand.flv" test="blablabla">bestand</a>
<a target="_blank" href="Titels_opdrachten.pdf"><strong>titels van opdrachten in OLAT</strong></a>
<a id="5quot;>test</a>
<a href="hallo.png">hallo</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href="$2">$4</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)