re = /<a (.*?)href="(.+?)"(.*?)>(.*?)<\/a>/im
str = '<a href="http://www.google.be">Google</a>
<a href="bestand.flv" test="blablabla">bestand</a>
<a target="_blank" href="Titels_opdrachten.pdf"><strong>titels van opdrachten in OLAT</strong></a>
<a id="5quot;>test</a>
<a href="hallo.png">hallo</a>'
subst = '<a href="$2">$4</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result