# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!LTD|LIMITED)\b\w+\b/"$1"/gm;t' <<< "ABC
ABC LTD
ABC LTD UK
LTD ABC
LTD UK ABC LIMITED"