import Foundation
let pattern = #"(?!LTD|LIMITED)\b\w+\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ABC
ABC LTD
ABC LTD UK
LTD ABC
LTD UK ABC LIMITED
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""$1""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)