use strict;
my $str = 'ABC
ABC LTD
ABC LTD UK
LTD ABC
LTD UK ABC LIMITED';
my $regex = qr/(?!LTD|LIMITED)\b\w+\b/mp;
my $subst = '"$1"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";