$re = '/(?!LTD|LIMITED)\b\w+\b/m';
$str = 'ABC
ABC LTD
ABC LTD UK
LTD ABC
LTD UK ABC LIMITED';
$subst = "\"$1\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;