using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!LTD|LIMITED)\b\w+\b";
string substitution = @"""$1""";
string input = @"ABC
ABC LTD
ABC LTD UK
LTD ABC
LTD UK ABC LIMITED";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}