import re
regex = re.compile(r"(?!LTD|LIMITED)\b\w+\b", flags=re.MULTILINE)
test_str = ("ABC\n"
"ABC LTD\n"
"ABC LTD UK\n"
"LTD ABC\n"
"LTD UK ABC LIMITED")
subst = "\"$1\""
result = regex.sub(subst, test_str)
if result:
print(result)