#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(lang=)[^&#]*"
Local $sString = "http://winner.com/?page=home&lang=es&lang=en&lang=es&bas=2" & @CRLF & _
"" & @CRLF & _
"http://winner.com/?page=home&lang=es&lang=en#hash" & @CRLF & _
"" & @CRLF & _
"http://winner.com/?page=home&lang=es&lang=en&lang=es&base=2#hash" & @CRLF & _
"" & @CRLF & _
"http://winner.com/test.html#HashValue?lang=QueryValue"
Local $sSubst = "$1en"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)