import re
regex = re.compile(r"(lang=)[^&#]*")
test_str = ("http://winner.com/?page=home&lang=es&lang=en&lang=es&bas=2\n\n"
"http://winner.com/?page=home&lang=es&lang=en#hash\n\n"
"http://winner.com/?page=home&lang=es&lang=en&lang=es&base=2#hash\n\n"
"http://winner.com/test.html#HashValue?lang=QueryValue")
subst = "$1en"
result = regex.sub(subst, test_str)
if result:
print(result)