import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(lang=)[^&#]*";
final String string = "http://winner.com/?page=home&lang=es&lang=en&lang=es&bas=2\n\n"
+ "http://winner.com/?page=home&lang=es&lang=en#hash\n\n"
+ "http://winner.com/?page=home&lang=es&lang=en&lang=es&base=2#hash\n\n"
+ "http://winner.com/test.html#HashValue?lang=QueryValue";
final String subst = "$1en";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}