using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(lang=)[^&#]*";
string substitution = @"$1en";
string input = @"http://winner.com/?page=home&lang=es&lang=en&lang=es&bas=2
http://winner.com/?page=home&lang=es&lang=en#hash
http://winner.com/?page=home&lang=es&lang=en&lang=es&base=2#hash
http://winner.com/test.html#HashValue?lang=QueryValue";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}