re = /(lang=)[^&#]*/
str = 'http://winner.com/?page=home&lang=es&lang=en&lang=es&bas=2
http://winner.com/?page=home&lang=es&lang=en#hash
http://winner.com/?page=home&lang=es&lang=en&lang=es&base=2#hash
http://winner.com/test.html#HashValue?lang=QueryValue'
subst = '$1en'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result